Jump to content

Check out the Lincoln Aviator Community Here.





kthiel

SYNC 3 screen blacks out or freezes

Recommended Posts

2019 Nautilus and within a week of ownership - 90% of the time that i start the car at home one of the following happens: the SYNC screen sometimes goes completely black - except when I stop and then the back up cameras pop up.  Sometimes, the back up cameras stay on while I am driving down the road.  Sometimes, the screen freezes, except for the gps map which shows my location as I drive, but the temp and time is frozen - but I can still change the heat (just the number on the screen doesnt change).  The radio volume can be adjusted but the station cant be changed - and if the radio was off the last time the car was shut off - I cant turn it on (and the other way also - cant turn if off).

It happens away from the house very rarely and Dealer cant replicate but I have taken it to them while its not working so they do understand.  They ultimately replaced the APIM.  Good for a week.  I had to reset the Lincoln Way app because of the new part - and installed the phones.  And selected the Auto Update with wifi access and I am right back where I started - with a non working SYNC screen.  I can do the reset (volume button, +-) away from the house and it will reset and usually work from there on out.  The dealer "computer" doesnt show any error messages so the next appointment - I am bringing the car in with a bad screen (not hard to do) - and leave it running.

I am starting to think its the wifi access and or Auto update.  I manually clicked on the sync to do an update scan - and it just couldnt do it thru the wifi even though it is seen - and it spins and spins.  I let it scan for updates through my phone using the Lincoln App and it seemed to be fixed for a couple cycles.  Then its back again.  I turned off all the wifi, updates, etc and it seems to work.  

Of course, I thought I had it figured out before - and then it fails when I thought I had already eliminated the situation.  I think it might fail away from home on occasion because I allow sync to look for open wifi - and do an auto update.. and perhaps I am near a wifi.  It fails significantly less away from home. 

I have done trial and error for hours and its hard to get a consistent cause/effect but I am growing weary.  

Anyone else have this issue? 

Share this post


Link to post
Share on other sites

Have the dealer come get it and replace the whole system.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×