Jump to content






Welcome to the Lincoln MKX Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKX Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Lincoln MKX Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo gallery and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Heated/Cool Front Seats


  • Please log in to reply
8 replies to this topic

#1 OFFLINE   gstein

gstein

    New Member

  • MKX Member
  • Pip
  • 5 posts
  • Region:U.S. Mississippi Valley
  • LocationIllinois
  • Current Vehicle:MKX 2016
  • My MKX's Year:2011-2014

Posted 23 December 2015 - 01:41 AM

I have had my new 2016 MKX back to the shop three time.  The bottom seat portion of the passenger seat is not heating nor cooling like the drivers seat.  The temperature difference is about 10 degrees different.  They have made some improvements but it still does not heat the entire seat.  It sure doesn't work like the passenger seat.  Has anyone else experienced such a problem.  







Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   enigma-2

enigma-2

    MKX Member

  • MKX Member
  • PipPip
  • 630 posts
  • Region:U.S. Great Lakes
  • LocationIndiana
  • Current Vehicle:2009 Lincoln MKX
  • My MKX's Year:2007-2010

Posted 23 December 2015 - 01:12 PM

I have an 09 so don't have this problem. But there has been a rather lenghtly discussion about seat cooling in the 2015 Edge forum: (6 pages).

http://www.fordedgef...e-1#entry137792

Seat heating is also a problem:
http://www.fordedgef...e-1#entry141919

#3 OFFLINE   mmoretti

mmoretti

    MKX Member

  • Banned
  • PipPip
  • 215 posts
  • Region:U.S. Northeast
  • LocationNJ
  • Current Vehicle:2015 Lincoln MKC Reserve AWD
  • My MKX's Year:None

Posted 23 December 2015 - 02:14 PM

My 2015 MKC had issues with the seats, its well covered in the mkc forum

 

http://www.mkcforum.com/

 

My seat backs didn't cool and it took forvever to even get my seats warm..  There's a TSB for the 2015 MKC.  I had it done and although the procedure fixed my cooling seat backs, there was minimal change to the heating.  It has to do with the way the system is designed.  My husband has an Escape Titanium and his seats heat very hot and very fast.  There is no cooling so its a completely different system.  Its discussed at length in the MKC forum.  My seats eventually get warm but it takes almost 15 minutes and by then I'm usually at my destination LOL.

 

From what I hearing from the 2016 owners there is improvement in this but overall the seats are still "slow" to heat in comparison to most other systems (like my Cadillac and the escape)  Disappointing to hear they have not improved upon this much in the new MKX which was my hope.

 

Also for those that do not know, the system works off of "ambient" temperature, so having your heat or A/C on will obviously get it to heat/cool quicker....

Hope this isolated for the MKX and not a big thing like the MKC's


Edited by mmoretti, 23 December 2015 - 02:46 PM.


#4 OFFLINE   Cosmos36

Cosmos36

    MKX Member

  • MKX Member
  • PipPip
  • 864 posts
  • Region:U.S. Pacific Coast
  • LocationOregon & Pacific NW wonderland
  • Current Vehicle:2010 Fusion, 2012 Veloster, 2016 MKX 2.7 AWD Select plus
  • My MKX's Year:None

Posted 23 December 2015 - 04:11 PM

The 'Cooling Seat Issue' is a Sticky over on the 2015 www.f150forum.com. It would appear that Ford's approach to heating/cooling seats needs some attention.



#5 OFFLINE   Ninja279

Ninja279

    New Member

  • MKX Member
  • Pip
  • 33 posts
  • Region:U.S. Great Lakes
  • LocationChicago
  • Current Vehicle:2016 - MKX 2.7L, Black Label
  • My MKX's Year:None

Posted 15 April 2017 - 03:58 PM

I just picked up my 2016 MKX. I too have found the passenger seat heating system to be wanting (dealer says they are working correctly). Used a directional thermal temperature reader and found the seat seemed to only heat at the very back portion, so there is no heating in the middle or the front. I did record a temperature of 105 degrees so the system actually works, but where the heaters are placed could just be a design flaw


Edited by Ninja279, 18 April 2017 - 08:08 PM.


#6 OFFLINE   Flipper

Flipper

    New Member

  • MKX Member
  • Pip
  • 2 posts
  • Region:Canada Ontario
  • LocationOttawa
  • Current Vehicle:2017 MKX
  • My MKX's Year:None

Posted 18 April 2017 - 07:47 PM

I have a 2017 MKX. Same problem with the passenger side seat bottom. Seat back works fine. Anyone find a solution to this yet?

#7 OFFLINE   Ninja279

Ninja279

    New Member

  • MKX Member
  • Pip
  • 33 posts
  • Region:U.S. Great Lakes
  • LocationChicago
  • Current Vehicle:2016 - MKX 2.7L, Black Label
  • My MKX's Year:None

Posted 18 April 2017 - 08:10 PM

I think the solution will require Ford engineering redesigning the seats


  • thisguy159 likes this

#8 OFFLINE   akirby

akirby

    MKX Member

  • Moderator
  • PipPip
  • 809 posts
  • Region:Decline
  • LocationSuwanee, GA
  • Current Vehicle:2016 Lincoln MKX Reserve
  • My MKX's Year:None

Posted 18 April 2017 - 10:47 PM

I think the solution will require Ford engineering redesigning the seats


This. ^^^

#9 OFFLINE   mobbdeep1122

mobbdeep1122

    New Member

  • MKX Member
  • Pip
  • 4 posts
  • Region:U.S. Northeast
  • LocationPhiladelphia
  • Current Vehicle:2013 MKX
  • My MKX's Year:2011-2014

Posted 16 May 2017 - 08:15 AM

I'm currently having an issue on my '13 MKX when I press the icon on the touchscreen for heated and cooled seats, only 2 lights illuminate. The lights stay on for the duration of the drive, but it doesn't seem like the heat/AC is working in the seat. This is the same for both driver and passenger side.Has anyone else experienced this?


Edited by mobbdeep1122, 16 May 2017 - 08:16 AM.







Custom Search


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·