Jump to content






Welcome to the Lincoln MKX Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKX Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Lincoln MKX Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo gallery and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

I lost the 'posted speed limit' box on the speedometer and can't find it again

dashboard icons

  • Please log in to reply
53 replies to this topic

#1 OFFLINE   meg

meg

    New Member

  • MKX Member
  • Pip
  • 12 posts
  • Region:U.S. Mountain
  • LocationCheyenne, WY
  • Current Vehicle:2016 Lincoln MKX
  • My MKX's Year:Decline

Posted 03 December 2016 - 10:51 AM

I purchased my MKX in August and took it in for it's first service this week.  I noticed the little 'posted speed limit' box that was in the speedometer is now gone.  I have poured through the owners manual, take the car back to the dealer and spoke with Lincoln Customer Service and no one can tell me how to get that little info box back again.  I found it very useful when driving in areas I'm not familiar with to know what the speed limit is. 
Any similar experiences or would anyone know how to get it back?  I'm assuming it's part of the navigation system.  I appreciate your help.

I found this pic on the internet to show location..it's the little white box in the speedometer.

Attached Files







Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   Cosmos36

Cosmos36

    MKX Member

  • MKX Member
  • PipPip
  • 922 posts
  • Region:U.S. Pacific Coast
  • LocationOregon & Pacific NW wonderland
  • Current Vehicle:2010 Fusion, 2012 Veloster, 2016 MKX 2.7 AWD Select plus
  • My MKX's Year:None

Posted 03 December 2016 - 12:18 PM

Yes, the speed limit display is linked to the navigation system. However, if your display functions as mine does, it is not a constant display and appears/disappears as I move about. Occasionally, the speed limit displayed is not correct. Also, it intermittently displays depending on the vehicle's location and highway, i.e. it displays on some highways and not others, seemingly not functioning within city limit side streets, some rural roads, etc.


Edited by Cosmos36, 03 December 2016 - 01:03 PM.


#3 OFFLINE   akirby

akirby

    MKX Member

  • Moderator
  • PipPip
  • 925 posts
  • Region:Decline
  • LocationSuwanee, GA
  • Current Vehicle:2016 Lincoln MKX Reserve
  • My MKX's Year:None

Posted 03 December 2016 - 01:35 PM

It only shows where it has data - check the Nav screen.



#4 OFFLINE   meg

meg

    New Member

  • MKX Member
  • Pip
  • 12 posts
  • Region:U.S. Mountain
  • LocationCheyenne, WY
  • Current Vehicle:2016 Lincoln MKX
  • My MKX's Year:Decline

Posted 03 December 2016 - 01:57 PM

Thank you for responding.  I no longer have this 'speed limit posting box' in the  exact same areas and hwy's I had it last week.  So this is normal?



#5 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 03 December 2016 - 02:07 PM

Not normal. This morning ours still showed up. Later on we will be going to an event. I'll check to see if it's still functioning properly.
  • meg likes this

#6 OFFLINE   akirby

akirby

    MKX Member

  • Moderator
  • PipPip
  • 925 posts
  • Region:Decline
  • LocationSuwanee, GA
  • Current Vehicle:2016 Lincoln MKX Reserve
  • My MKX's Year:None

Posted 03 December 2016 - 04:14 PM

No. try resetting the system by holding the radio on/off button and the right seek (>>|) buttons for a few seconds.

#7 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 03 December 2016 - 05:33 PM

Or is still working. I would try what akirby mentioned

#8 OFFLINE   meg

meg

    New Member

  • MKX Member
  • Pip
  • 12 posts
  • Region:U.S. Mountain
  • LocationCheyenne, WY
  • Current Vehicle:2016 Lincoln MKX
  • My MKX's Year:Decline

Posted 03 December 2016 - 06:20 PM

I'll try the resetting method above..it's a balmy 14 degrees out right now so will wait until tomorrow :)



#9 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 03 December 2016 - 06:53 PM

Come to think about it. I'm not sure resetting sync would work bc I believe the speed limit is linked to Sirius Travel Link

#10 OFFLINE   NOTMY911

NOTMY911

    MKX Member

  • MKX Member
  • PipPip
  • 437 posts
  • Region:Canada Ontario
  • LocationOttawa
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 06:41 AM

... I believe the speed limit is linked to Sirius Travel Link

 

 

My suscription ran out (only 6 month free in Canada) and its working fine.  Its part of the mapping which is really bad, i.e. not showing major highway that was completed in 2015.


"NOTMY911":  2016 MKX Reserve 102A, Ingot Silver, 3.7 AWD, Driver Assistance Pck, Technology Pck, Climate Pck, 22 Way Seats, Sync 3  

 

"JJ 911SC":     1983 911 Cabriolet, Grand Prix White


#11 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 08:13 AM

My suscription ran out (only 6 month free in Canada) and its working fine. Its part of the mapping which is really bad, i.e. not showing major highway that was completed in 2015.


Thanks for clarifying. I am glad it still works even after subscription terminates. Hopefully we can get 2.0 update so we can use AA or Car Play. So far Sync3 mapping has been good for me (in the US) for the areas I've traveled to. Also, at least, for my experience it picks out the "best" & fastest route.

#12 OFFLINE   Cosmos36

Cosmos36

    MKX Member

  • MKX Member
  • PipPip
  • 922 posts
  • Region:U.S. Pacific Coast
  • LocationOregon & Pacific NW wonderland
  • Current Vehicle:2010 Fusion, 2012 Veloster, 2016 MKX 2.7 AWD Select plus
  • My MKX's Year:None

Posted 04 December 2016 - 02:14 PM

Just a reminder...the SiriusXM Traffic & Travel link is available for 6 years in the U.S.

 

Edited to correct term of Sirius T&L to 6 years from incorrectly stated 5 years.


Edited by Cosmos36, 04 December 2016 - 05:18 PM.


#13 OFFLINE   Chile Rick

Chile Rick

    New Member

  • MKX Facebook Member
  • Pip
  • 10 posts
  • Region:U.S. Pacific Coast
  • Locationpalm desert
  • Current Vehicle:2019 MKX reserve
  • My MKX's Year:Decline

Posted 04 December 2016 - 04:01 PM

I thought it only worked with cruise control on.......
Showing your current cruise speed below ( or your resume speed in not activated )

Edited by Chile Rick, 04 December 2016 - 04:06 PM.


#14 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 04:36 PM

I thought it only worked with cruise control on.......
Showing your current cruise speed below ( or your resume speed in not activated )



No mine displays automatically (I've never used CC)

#15 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 04:37 PM

Just a reminder...the SiriusXM Traffic & Travel link is available for 5 years in the U.S.


I thought it was for 6 yrs in US. I may be wrong.
  • Cosmos36 likes this

#16 OFFLINE   Cosmos36

Cosmos36

    MKX Member

  • MKX Member
  • PipPip
  • 922 posts
  • Region:U.S. Pacific Coast
  • LocationOregon & Pacific NW wonderland
  • Current Vehicle:2010 Fusion, 2012 Veloster, 2016 MKX 2.7 AWD Select plus
  • My MKX's Year:None

Posted 04 December 2016 - 05:06 PM

Yes, six years is correct...same as the powertrain warranty. Thanks.


Edited by Cosmos36, 04 December 2016 - 05:21 PM.


#17 OFFLINE   meg

meg

    New Member

  • MKX Member
  • Pip
  • 12 posts
  • Region:U.S. Mountain
  • LocationCheyenne, WY
  • Current Vehicle:2016 Lincoln MKX
  • My MKX's Year:Decline

Posted 04 December 2016 - 05:44 PM

I tried resetting per the instructions and it didn't work :(  I also noticed that the speed limit box is not on the navigation screen.  I've never used the cruise control and it was always been there.

 

Anymore ideas how I can get the little box back?



#18 OFFLINE   NOTMY911

NOTMY911

    MKX Member

  • MKX Member
  • PipPip
  • 437 posts
  • Region:Canada Ontario
  • LocationOttawa
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 07:07 PM

I thought it only worked with cruise control on.......
Showing your current cruise speed below ( or your resume speed in not activated )

 

 

Totaly unrelated. 


"NOTMY911":  2016 MKX Reserve 102A, Ingot Silver, 3.7 AWD, Driver Assistance Pck, Technology Pck, Climate Pck, 22 Way Seats, Sync 3  

 

"JJ 911SC":     1983 911 Cabriolet, Grand Prix White


#19 OFFLINE   mfam16

mfam16

    MKX Member

  • MKX Member
  • PipPip
  • 254 posts
  • Region:U.S. Southern Plains
  • LocationSouth East
  • Current Vehicle:2016 MKX
  • My MKX's Year:None

Posted 04 December 2016 - 08:38 PM

I tried resetting per the instructions and it didn't work :( I also noticed that the speed limit box is not on the navigation screen. I've never used the cruise control and it was always been there.

Anymore ideas how I can get the little box back?

The only two additional options I can think of are:
1. Maybe an incomplete software update occurred and you have file corruption for that feature - in turn get service to reflash sync. From what I've heard they should have version 1.1

2. Try hard/master reset by disconnecting battery terminal and waiting a minute or two then reconnect. This solved my issue of app not properly communicating with modem.

Hope this helps

Edited by mfam16, 04 December 2016 - 08:38 PM.


#20 OFFLINE   walkabout

walkabout

    MKX Member

  • MKX Member
  • PipPip
  • 428 posts
  • Region:Decline
  • LocationLos Angeles
  • Current Vehicle:Lincoln Mkx
  • My MKX's Year:Decline

Posted 05 December 2016 - 09:55 AM

Btw, my sync 3 was replaced a few weeks back. Since it is a new unit, it should have the latest is (in theory). It is running 1.0.






Custom Search


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·