Jump to content






Welcome to the Lincoln MKX Forum


Sign In  Log in with Facebook

Create Account
Welcome to the Lincoln MKX Forum. You must register to create topics or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of the Lincoln MKX - Lincoln Nautilus Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo gallery and post images. . .more!
Click here to create an account
 
Guest Message by DevFuse

Photo
- - - - -

Turn signals


  • Please log in to reply
5 replies to this topic

#1 OFFLINE   Gdaddypaul

Gdaddypaul

    New Member

  • MKX Member
  • Pip
  • 2 posts
  • Region:U.S. Southern Atlantic
  • LocationEllicott City, MD
  • Current Vehicle:2013 MKX

Posted 29 November 2016 - 10:37 PM

Came out this morning and discovered the passenger side tail light was lighted (car not even started yet). Further, the right turn signal excited the flasher to click rapidly, like a bulb was burned out. Changed both the front and rear bulbs to no avail. Anyone had this experience? Suggestions?
Thanks!





Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   JustDriver

JustDriver

    New Member

  • MKX Member
  • Pip
  • 9 posts
  • Region:U.S. Southern Atlantic
  • LocationBronx, NY
  • Current Vehicle:F-150 2015, 2008 MKX
  • My MKX's Year:2007-2010

Posted 07 March 2017 - 10:27 AM

Sounds like a short circuit. I am not an electrician, but I would make sure the relay is okay. In any case, a good electricial will help you diagnose the problem. Yet, it's better to do that asap not to end up with the dead battery one morning...



#3 OFFLINE   enigma-2

enigma-2

    MKX Member

  • MKX Member
  • PipPip
  • 991 posts
  • Region:U.S. Great Lakes
  • LocationIndiana
  • Current Vehicle:2009 Lincoln MKX
  • My MKX's Year:2007-2010

Posted 07 March 2017 - 01:21 PM

In looking at the electrical schematic for the Edge, there does not seem to any common point where both circuits could become energized; except both originate at the smart Junction Box (commonly referred to as the fuse panel).

That the turn signal was flashing fast indicates that the FET was not "seeing" the front right turn lamp. Yet we know it is good. Therefore I would suspect corrosion or a short in the Smart Junction Box.

I can't see where there is any other point where both circuits could become energized (only on the right side).

As Just Driver said, needs to be looked at asap. Not just a dead battery concern, I would also be concerned over a short.

Edited by enigma-2, 07 March 2017 - 01:24 PM.


#4 OFFLINE   enigma-2

enigma-2

    MKX Member

  • MKX Member
  • PipPip
  • 991 posts
  • Region:U.S. Great Lakes
  • LocationIndiana
  • Current Vehicle:2009 Lincoln MKX
  • My MKX's Year:2007-2010

Posted 07 March 2017 - 01:32 PM

Just to clarify, the stop/turn lamp is flashing rapidly and the parking lamp is on steady? What year car do you have?

#5 OFFLINE   Gdaddypaul

Gdaddypaul

    New Member

  • MKX Member
  • Pip
  • 2 posts
  • Region:U.S. Southern Atlantic
  • LocationEllicott City, MD
  • Current Vehicle:2013 MKX

Posted 16 March 2017 - 06:59 PM

Turns out the problem is with the "transformer" with the trailer hitch. Am trying to contact the vendor.



#6 OFFLINE   enigma-2

enigma-2

    MKX Member

  • MKX Member
  • PipPip
  • 991 posts
  • Region:U.S. Great Lakes
  • LocationIndiana
  • Current Vehicle:2009 Lincoln MKX
  • My MKX's Year:2007-2010

Posted 17 March 2017 - 12:03 AM

I wasn't aware of any transformer in a hitch circuit. Transformers work with alternating current. There are only direct current circuits on the Edge.






Custom Search


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·